
Introduction to VMWare workstation

0.1 Creating Ubuntu Guest

0.1.1 Create new Ubuntu 10.04 virtual machine using VMWare
workstation 7.0

1. Choose menu option to create new virtual machine (“File → New →

Virtual Machine”)

2. Choose ”Custom (Advanced)” mode for creating

3. Choose latest hardware compatibility “Workstation 6.5-7.x” as we want
to use latest features and we are not going to port it on older versions
any way.

4. We can choose installer disc image file from Data drive. Choosing
Ubuntu 10.04 DVD ISO stored within ‘operating sytems/ubuntu/10.04’
folder will cause VMWare to detect Ubuntu OS and enable easy install.
Now easy install has advantage that VMWare tools automatically get
installed. VMWare tools install VMWare drivers for guest OS making
it perform much better so that VMWare does not needs to emulate
complete devices for guest OS.

But easy install does not works well for “Ubuntu 10.04” and there is no
option of disabling easy install in this window. So best is to choose “I
will install operating system later” option now. We can add CD Drive
later in “Customize hardware” option before finalizing the VM.

5. Choose Guest Operating System as Linux specifically “Ubuntu”

6. Enter virtual machine name. Virtual machine files ‘.vmdk’ and ‘.vmx’
will be created with this name. Also choose folder where these files
should get stored. Note that there must be sufficient space (>=10GB)
in destination folder to store file which will get used as hard-disk for
this virtual machine.

7. Choose 1 processor for this VM

8. Give “512 MB” RAM to this VM

9. There are four options available for VM networking:

Use bridged networking : When we use this option the VM shares
the network card with host machine. The host machine network
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card operates in bridge mode and both host and guest OS use the
same network card. Both of them use separate LAN IP addresses
and can send packets to network / receive packets from network
directly.

This is preferred option on trusted networks or if other hosts on
network should be able to initiate connections to VM. If VM does
not has its own LAN IP then other hosts on LAN will not be able
to initiate connection to it and hence will not be able to access
web server, ftp server etc. running on VM without some kind of
port forwarding from host OS.

Use network address translation (NAT) : This option will cause
all the packets from guest to be labelled with host machines LAN
IP address when they leave the network interface. Also when the
reply comes back the destination IP address will automatically get
changed to VMs IP address and hosts IP address will get removed.

Hence as far as all other machines on LAN are concerned the
connection request seems to come from host machine. Only host
machine is aware whether the connection is its own or it is for-
warding connection on behalf of some VM. This is very secure as
machines on LAN are not aware of presence of VM and they cant
initiate connection to VM. This also again has limitation as now
we can’t run web server, ftp server etc. on VM for other machines
on LAN to be able to access these servers.

This method is useful if host machine is directly connected to
internet and has a pulbic IP. Using this method we do not need
separate public IP for each VM. Also firewall rules, IPS programs
running on host can scan / filter traffic generated to/for guests
VMs making sure all VMs are secured. Even rate limiting can be
applied by host OS for guest OS network connections.

Use host-only networking : This option means that only host would
be aware of and would be able to initiate connections / receive
connection requests from guest. Guest would not be available /
connect to outside network at all. This is the safest option as
guest is like local application not having access to LAN/Intenet.

This is good option if we want to test some application using
virtualization without worrying about security issues.

Do not use a network connection : This is useful if we do not
want any kind of network option for guest OS. This option is
useful for system security analyzers who deassemble viruses and
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study their behavior. We can infect a virtual machine with no
network connection with virus and study how virus works without
worrying about it spreading into host OS or LAN.

For purpose of lab choose “Bridged networking”

10. Choose IDE controller as ATAPI and SCSI controller as “LSI Logic”

11. Create a new virtual disk for the VM

12. Choose the virtual disk type as “SCSI”

13. Give 10.0GB space to virtual disk and choose to allocate disk space now.
Unlike ext3 and other Linux partitions NTFS and FAT filesystems that
we use on Windows tend to get fragmented.

Hence it is best to allocate entire space at once so that we get contiguos
disk blocks and hence better performing VM. Store the contents in
single file. Note that the filesystem should be “NTFS” and not “FAT”
as we cant create files of size > 4GB on FAT file systems. Hence it is
necessary to choose NTFS file system to store disk image of the VM
we are going to create.

14. Use the default name of VM file suggested unless you have a good
reason to change it.

15. On final screen you get option of customizing hardware for new virtual
machine. This is useful in case one needs two different network adapters
on new Virtual machine or one more harddisk etc. Option of staring
new VM as soon as it is created is also present on this screen.

Do the following changes to hardware for installing Ubuntu:

• Click on Network adapter in list and change from “Bridged: Con-
nected directly to physical network” to “Custom: VMnet0 (Auto-
bridging)”.

• Click on new CD/DVD (IDE) in list and choose “Ubuntu 10.04
ISO” image from ‘operating sytems/ubuntu/10.04’ folder of data
drive. Choose that device remains connected at power on.

Browse through other options in “Customize Hardware” window and
then finish creating VM.

Note:
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1. VMWare will create 10.0 GB disk image for the new VM
before starting the VM.

2. In labs since we are using evaluation version of VMWare you
might get prompted for entering license key. For obtaining li-
cense key one needs to register on http://www.vmware.com/
and choose product “VMWare workstation”. Then choose
option “Try now” from image at top. This will ask you to
login using VMWare website login.

If you do not have VMWare website login then you can reg-
ister for free. Once you are logged in using VMWare login
you are asked whether you agree to terms and conditions
for trying VMWare workstation. Once you agree you would
receive email with activation link.

Visiting the activation link shows the license key at top
which would make VMWare workstation work for 30 days
which is good enough for lab purposes.

0.1.2 Powering on VM and installing Ubuntu

Now we would get tab and also option of Ubuntu VM in tree list in VMWare
workstation window. We get options of starting virtual machine or also of
editing virtual machine settings.

Note that when we edit virtual machine settings we do not get option of
choosing boot order. Most Virtualization solutions allow you to choose boot
order so that we can specify whether VM should boot from CD/DVD drive
for OS installation or from hard-disk for normal boot.

When we use VMWare for virtualization we can change boot order for
VM BIOS. We have to start VM and press ‘F2’ key to go into VM BIOS.
WIthin VM BIOS we get option of choosing boot order for VM. Choose to
boot from CD-ROM before hard-disk.

Note that:

1. You need to click on the display area so that keystrokes are actually
received by VM and then press ‘F2’. This needs to be done quickly as
VM will not wait long time for user to press F2 key.

2. VMWare Workstation supports something called “Easy install” for in-
stallation of Ubuntu. What this means is that we can supply username,
password etc. information while creating VM we wont have to enter
same information during installation and VMWare will supply that in-
formation on our behalf. This allows uniterrupted install so that no
user intervention is required.
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This does not works well with Ubuntu 10.04 and hence we intention-
ally avoided Easy install. Interested students can try easy install for
“Ubuntu 8” where it might work well.

3. If while using Bridged networking VM is not able to connect to network
and get IP address from DHCP then edit settings for VM (It can be
done even when it is running).

Go to settings for network adapter and change network from “Bridged:
Connected directly to physical network” to “Custom: VMnet0 (Auto-
bridging)”.

One can find information about VM virtual networks from “Virtual
Network Editor” application whose shortcut is available in VMWare
folder in start-menu. Virtual network editor can also be launched using
“Edit → Virtual network editor” menu option from VMWare worksta-
tion.

When the VM boots we can install Ubuntu as we would do not normal
machine. Choose:

1. English

2. Install Ubuntu on local machine

3. English

4. Region:Asia, Time Zone: India Time

5. Keyboard layout: Suggested option: USA

6. Choose to specify partitions manually

7. Choose disk ‘/dev/sda’ and create new partition table for the disk

8. Now click on “free space” and choose “Add” option

9. Create new partition with following options

(a) Type of partition: Primary

(b) Size: maximum value - 1024 (That is subtract 1024 from default
that appears on clicking add)

(c) Location for partition begining

(d) Use as: Ext3 journaling file system

(e) Mount point: /
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Click Ok to create partition.

10. Again click on “free space” amd choose “Add” option. Create new
partitions with following values:

(a) Type of partition: Primary

(b) Size: 1024 MB

(c) Location: Begging

(d) Use as: Swap area

Click Ok to create parition

11. Click on Forward to go to next screen after both ’/’ and swap partitions
are specified.

12. Enter name, username, password, pc name, require password to login
etc. details

13. Click on advanced and enter network proxy as “http://proxy.iiit.ac.in:8080/”.

14. Click on Install button to begin installation

15. Click on restart button to restart OS

16. Ensure that CD/DVD is disconnected by looking at device icons at
bottom right screen of VMWare workstation and confirm same to in-
stallation program by pressing ‘enter’.

Machine should now reboot and you should get ubuntu login window
after a while. If VM hangs then go to VM Settings and disconnect “Ubuntu
10.04” Installation ISO and also disable it on VM boot. Then reset the
machine. Now machine should boot properly. If it hangs even now then
there is problem with installation and contact TA/Instructor for help.

0.1.3 Installing VM Tools in Ubuntu 10.04

1. Choose “VM → Install VMWare tools” options.

2. Copy VMWare tools tar.gz file from mounted CD ROM to some other
location

3. Extract the .tar.gz file as root user (Use “sudo su -” and user password
entered during installation to login as root). Use command “tar xzf
<tar.gz file name>” to extract files.
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4. Go inside folder “vmware-tools-distrib”

5. Run file ‘vmware-install.pl’ using “./vmware-install.pl”

6. During installation lot of questions will be asked. Use default values for
all questions by just pressing “Enter” key at all prompts. Let vmware
tools configuration program run at end of installation.

7. Copy the important messges regarding how to enable VM Tools, how to
enable VM network driver and how to uninstall VM Tools etc. in text
file so that we do not loose this information when we restart X-session.

8. Start ”/usr/bin/vmware-user”

9. Log off and log back in. For log out use the power button at top-right
corner of screen.

10. Again open text file created during installation and copy few words of
text from it. Try to paste the content on host OS. If you are able
to copy/paste text between guest and host OS then installation of
VMWare tools is successful.

11. Try dragging and dropping files between guest and host OS to check
whether “drag/drop” feature of VMWare tools is working properly or
not.

12. You can run ‘/usr/bin/vmware-toolbox’ to get VMWare tools con-
figuration dialog box.

0.2 Moving virtual machine

To move virtual machine follow these steps:

1. Power off virtual machine

2. Remove it from list of favorites

3. Move all files related to VM to new location. This may take long time
as VM disk could be 10 GB in size and would take considerable time
to move, specially if you move from one partition to other.

4. Again open Virtual machine and add it to favorites.

5. When you boot VM again VMWare workstation would ask whether
you had moved the VM or copied it? Choose “moved it”.
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0.3 Create Windows XP virtual machine

0.3.1 Create VM for Windows XP

1. 1. Choose “File → New → Virtual Machine” from menu bar.

2. Choose “Custom (Advanced)” mode

3. Create VM for latest workstation versions

4. Choose Windows XP ISO file from data drive. It is stored in “/operat-
ing systems/windows xp sp2” folder. As soon as we select file installer
will detect Windows XP OS and enable “Easy Install” mode. We can
use “Easy Install” mode for installing Windows XP.

For Ubuntu we intentionally omitted this mode as it causes problem.
This will allow uniterrupted installation of Windows and relieves user
from waiting for Windows OS to ask queries during installation.

5. Enter windows product key and name. We can leave password blank
or use some common password if required. You can use Volume license
key used in IIIT for installation during labs.

6. Give name “Windows XP” to virtual machine. Note that spaces have
intentionally been omitted from file names so that they are easy to
copy from command line. . Choose location where enough disk space
(>=6.0GB) is available. If you are planning to install applications like
Open Office in Windows then you can choose even large disk size and
hence correspondingly partition with even more free space.

7. Choose number of processors as one. It is best to give only one processor
to each VM so that even if it hangs the host OS is responsive and we
can force off /reset VM. If the host OS has quad core or eight core
processor then we can give more then one processor to VM without
worrying about guest OS causing performance problem for host OS.

8. Give 512 MB RAM for this VM

9. Use bridged networking. Read the installation notes for Ubuntu to
understand difference between various networking options.

10. Use recommended “Bus logic” for SCSI controller during installation.

11. Create new Virtual disk for this VM

12. Create SCSI disk as recommended.
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13. Create 6.0 GB file for this VM. Allocate space now and store the entire
disk in single file.

14. Use the default name suggested for VM disk unless you have really
good reasons to change the name.

15. Click on “Customize adapter” and change network adapter from “Bridged:Connected
directly to physical network” to “Custom: VMnet0 (Auto-bridging)”.
Have a look at other options in the list.

16. Click finish to finish creating VM.

Now VMWare would actually create disk file for new VM. Also if VMWare
is not yet activated for evaluation you would be asked to enter license key be-
fore starting VM. See note after Ubuntu VM creation steps for understanding
how to obtain evaluation license key for VMWare.

VMWare tools will automatically get installed so we do not have to follow
extra steps to install VMWare tools on Windows XP VM, if we use easy
install option. Try to copy/paste or drag/drop things between Guest and
Host OS to verify that VMWare tools is installed properly.

0.3.2 Mount guest harddisk on host OS

1. Shut down windows XP virtual machine

2. Choose option “File → Map or disconnect virtual disks”

3. Click on “Map...”

4. Browse to folder where virtual machine is created and choose disk image
file (probably Wiindows XP.vmdk. (Do not choose Windows XP-flat).

5. Enable opening in read-only mode.

6. Click Ok and now guest OS files are accessible in host OS as normal
files.

7. Close the explorer window and disconnect mapped drives.

0.4 Lab task/qeuries

1. Install Ubuntu 10.04 on VMWare Workstation 7.0 VM

2. Install VMWare tools in installed Ubuntu VM.
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3. Install Windows XP on VMWare Workstation 7.0 VM

4. Why VMWare workstation recommends bus logic for Windows OS and
LSI logic for Linux based OS?

5. Guess how easy install feature works for installation of different type
of Operating Systems without intervention.

6. Mount guest Windows XP harddisk on base OS.

7. Why we power off VM when we mount hard-disk? Can we just suspend
VM and then mount its hard-disk on host OS? What care must be taken
in each case when we mount guest OS files on host OS?

8. Use “Help → User manual” option from VMWare workstation menubar
to get latest VMWare user manual in PDF format. Save it and read it
before next lab so that you are aware of advanced features of VMWare
workstation that we will try in next lab.
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